Home / Forum / Admin Menü

Admin Menü

Um Zugang zu den Foren zu erhalten, müssen Sie angemeldet sein

Autor Nachricht

Daniel B

Registriert seit: 10.09.2009

Beiträge: 33

Mittwoch, 23. September 2009 09:26:04

Guten Morgen,

wie beeinflusse ich, dass im AdminMenü in der Baumstruktur das Plus und Minus Zeichen angezeigt wird, mit denen man eine untere Ebene öffnen kann.?

Danke

Thomas Köhn

Thomas Köhn

Registriert seit: 05.03.2007

Beiträge: 355

Mittwoch, 23. September 2009 15:59:07

Du kannst es über ShowClasses in der contentstructuremenu.ini.append.php in deinem Admin-Siteaccess steuern.

[TreeMenu]
ShowClasses[]
ShowClasses[]=folder

Dipl. Ing. (FH) M. Sc. Thomas Köhn

Senior Software Developer

ProSiebenSat.1 Digital GmbH
Ein Unternehmen der ProSiebenSat.1 Media AG

Daniel B

Registriert seit: 10.09.2009

Beiträge: 33

Mittwoch, 23. September 2009 16:27:47

ist aktiviert gewesen... aber kein Effekt

Thomas Köhn

Thomas Köhn

Registriert seit: 05.03.2007

Beiträge: 355

Donnerstag, 24. September 2009 14:21:42

Damit das '+' bzw '-' kommt müssen die Untereinträge aktiviert sein. Kommt ja nur, wenn auch etwas anzuzeigen gibt.

Bsp:

- Folder 1
-- Article 1
-- Article 2
--- File 1
-- Image 1
- Folder 2
-- Folder 3

[TreeMenu]
ShowClasses[]
ShowClasses[]=folder


Nur Folder 2 bekommt ein +/-

[TreeMenu]
ShowClasses[]
ShowClasses[]=folder
ShowClasses[]=article


Folder 1 und Folder 2 bekommen ein +/-

[TreeMenu]
ShowClasses[]
ShowClasses[]=folder
ShowClasses[]=article
ShowClasses[]=file


Folder 1, Folder 2 und Article 2 bekommen ein +/-

Dipl. Ing. (FH) M. Sc. Thomas Köhn

Senior Software Developer

ProSiebenSat.1 Digital GmbH
Ein Unternehmen der ProSiebenSat.1 Media AG

Daniel B

Registriert seit: 10.09.2009

Beiträge: 33

Montag, 28. September 2009 11:24:28

...aber es funktioniert

Wenn Du nochmal Muße hast, mir das zu erklären

Gruss und Danke
Daniel

Thomas Köhn

Thomas Köhn

Registriert seit: 05.03.2007

Beiträge: 355

Montag, 28. September 2009 11:33:17

Ich versuche es nochmal zusammen zu fassen.

1. Es werden im Admin-Menü nur Objekte angezeigt die auch in der Liste in der INI stehen.
2. Objekte im Admin-Menü sind nur auf-/zuklappbar, wenn unterhalb von ihnen Objekte angeordnet sind, die auch in der Liste in der INI stehen
3. Objekte die zwar in der Liste in der INI stehen, aber unterhalb eines Objektes angeordnet sind, dass nicht in Liste in der INI steht, können nicht angezeigt werden

Ich hoffe mal das hilft die letzte Unklarheiten zu beseitigen.

Dipl. Ing. (FH) M. Sc. Thomas Köhn

Senior Software Developer

ProSiebenSat.1 Digital GmbH
Ein Unternehmen der ProSiebenSat.1 Media AG

Daniel B

Registriert seit: 10.09.2009

Beiträge: 33

Montag, 28. September 2009 14:03:46

Jetzt hab ich´s

Um Zugang zu den Foren zu erhalten, müssen Sie angemeldet sein